wdrożenia PrestaShop Powiększenie zdjęć moduł

HTTP 500, upgrade wykrzaczył sklep!

  • 3 Odpowiedzi
  • 17 Wyświetleń

0 użytkowników i 1 Gość przegląda ten wątek.

*

Offline MindFlyer

  • Nowy
  • *
  • 2
  • 0
  • PrestaShop
  • Presta Shop: 1.6.1
  • Status: Programista
HTTP 500, upgrade wykrzaczył sklep!
« dnia: Maj 23, 2020, 01:08:36 pm »
Dzień dobry Panie, dzień dobry Panowie...

Piszę z prośbą o pomoc! Niestety próba upgradu Presty z 1.6.1.1 do 1.7.6.5 zakończyła się niepowodzeniem. Nic nie działa, wszędzie błędy http 500. Nie działa ani front, ani panel admina. Wcześniej server był ustawiony na php 5.6, ale teraz zmiana na 7.1, czy inne wersje również nie pomaga. Jak można to naprawić? Backup bazy danych mam, ale samych plików serwera niestety już nie.

Tryb debugowania pokazuje (póki co) tyle:

FRONT:

Fatal error: Class FrontControllerCore contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (ControllerCore::buildContainer) in /home/srv31777/domains/ebookipolihymnia.pl/public_html/override/classes/controller/FrontController.php on line 0
Podczas próby zalogowania do panelu admina pokazuję się poniższe informacje:

(1/1) PrestaShopDatabaseException
Table 'srv31777_ebooki.ps_currency_lang' doesn't exist<br /><br /><pre>SELECT *
FROM `ps_currency_lang`
WHERE `id_currency` = 4</pre>

in Db.php line 769
at DbCore->displayError('SELECT * FROM `ps_currency_lang` WHERE `id_currency` = 4')
in Db.php line 385
at DbCore->query('SELECT * FROM `ps_currency_lang` WHERE `id_currency` = 4')
in Db.php line 613
at DbCore->executeS('SELECT * FROM `ps_currency_lang` WHERE `id_currency` = 4')
in EntityMapper.php line 82
at EntityMapper->load('4', null, object(Currency), array('table' => 'currency', 'primary' => 'id_currency', 'multilang' => true, 'fields' => array('iso_code' => array('type' => 3, 'validate' => 'isLanguageIsoCode', 'required' => true, 'size' => 3), 'numeric_iso_code' => array('type' => 3, 'validate' => 'isNumericIsoCode', 'size' => 3), 'precision' => array('type' => 1, 'validate' => 'isInt'), 'conversion_rate' => array('type' => 4, 'validate' => 'isUnsignedFloat', 'required' => true, 'shop' => true), 'deleted' => array('type' => 2, 'validate' => 'isBool'), 'active' => array('type' => 2, 'validate' => 'isBool'), 'name' => array('type' => 3, 'lang' => true, 'validate' => 'isGenericName', 'size' => 255), 'symbol' => array('type' => 3, 'lang' => true, 'size' => 255)), 'classname' => 'Currency', 'associations' => array('l' => array('type' => 2, 'field' => 'id_currency', 'foreign_field' => 'id_currency'))), 2, true)
in ObjectModel.php line 264
at ObjectModelCore->__construct('4', null, null)
in Currency.php line 209
at CurrencyCore->__construct('4')
in AdminController.php line 2958
at AdminControllerCore->initShopContext()
in AdminController.php line 531
at AdminControllerCore->__construct()
in LegacyContext.php line 85
at LegacyContext->getContext()
in UserLocaleListener.php line 39
at UserLocaleListener->__construct(object(LegacyContext))
in appDevDebugProjectContainer.php line 2369
at appDevDebugProjectContainer->getPrestashop_UserLocale_ListenerService()
in appDevDebugProjectContainer.php line 2856
at appDevDebugProjectContainer->ContainerXxnolwy\{closure}()
in EventDispatcher.php line 229
at EventDispatcher->sortListeners('kernel.request')
in EventDispatcher.php line 61
at EventDispatcher->getListeners('kernel.request')
in ContainerAwareEventDispatcher.php line 128
at ContainerAwareEventDispatcher->getListeners('kernel.request')
in TraceableEventDispatcher.php line 262
at TraceableEventDispatcher->preProcess('kernel.request')
in TraceableEventDispatcher.php line 137
at TraceableEventDispatcher->dispatch('kernel.request', object(GetResponseEvent))
in HttpKernel.php line 127
at HttpKernel->handleRaw(object(Request), 1)
in HttpKernel.php line 68
at HttpKernel->handle(object(Request), 1, false)
in Kernel.php line 200
at Kernel->handle(object(Request), 1, false)
in index.php line 86

Bardzo na Was liczę!

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 5,164
  • 103
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: HTTP 500, upgrade wykrzaczył sklep!
« Odpowiedź #1 dnia: Maj 25, 2020, 10:11:43 am »
1. Przywróć bazę
2. Ściągnij czystą instalkę 1.6
3. Sprawdź poprawność działania sklepu
4 . Spróbuj zaktualizować ale z linii poleceń a nie przyciskiem upgrade
Powodem Twojego nieszczęścia jest niepełna aktualizacja bazy danych - skończył się czas na serwerze. Sugeruję lokalną instalkę xampp i upgrade, a dopiero później wrzucenie na serwer
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz 

*

Offline MindFlyer

  • Nowy
  • *
  • 2
  • 0
  • PrestaShop
  • Presta Shop: 1.6.1
  • Status: Programista
Odp: HTTP 500, upgrade wykrzaczył sklep!
« Odpowiedź #2 dnia: Maj 25, 2020, 11:26:46 am »
Dzięki west,

Już poradziłem sobie kopiując pliki z kopii technicznej hostingu...

Ale mimo wszystko mógłbyś mi teraz jeszcze raz napisać krok po kroku co zrobić, aby poprawnie zaktualizować moje sklepy (PRESTA działa w trybie MULTISTORE na dwóch różnych domenach)

Czy w ogóle jest mi potrzebna ta aktualizacja? Może wystarczy pracować na aktualnej wersji i nie aktualizować się do 1.7? Jakieś sugestie, podpowiedzi?

Wersja PRESTY: 1.6.1.24 (udało mi się zaktualizować z 1.6.1.1)
PHP na serwerze: 5.6

Serwer DB:
Serwer: Localhost via UNIX socket
Typ serwera: MariaDB
Wersja serwera: 10.4.12-MariaDB-cll-lve - MariaDB Server
Wersja protokołu: 10

Serwer WWW
LiteSpeed
Wersja klienta bazy danych: libmysql - mysqlnd 5.0.12-dev - 20150407
Rozszerzenie PHP: mysqli curl mbstring
Wersja PHP: 7.2.30

*

Offline west

  • Administrator
  • Mieszkaniec
  • *****
  • 5,164
  • 103
  • Płeć: Mężczyzna
  • Europasaz.pl
    • Projektowanie PrestaShop, Wordpress, SMF
  • Presta Shop: PS
  • Status: Programista
Odp: HTTP 500, upgrade wykrzaczył sklep!
« Odpowiedź #3 dnia: Maj 25, 2020, 11:24:16 pm »
Zostań raczej na 1.6
Jeśli musisz koniecznie najpierw zrób aktualizację lokalnie na komputerze . Ja zawsze używam shell do tego i xampp
MODUŁY | http://europasaz.pl |  SKLEPY INTERNETOWE | WSPARCIE TECHNICZNE | HOSTING | http://zielona.biz